SQL-Ledger Homepage

SQL-Ledger User Forum

Forum index page

Log in | Register

Back to index page
Thread view  Board view
Andreas Schweizer(R)

03.07.2015, 00:51
 

taxincluded=1 when using cli interface has no effect (General)

When I use the cli interface to programmatically add an invoice and the argument taxincluded=1 is given, the invoice is setup without taxincluded. The same happens when i want to post an invoice.

I use this url to add an invoice:
is.pl?path=bin/mozilla&action=add&type=invoice&...&taxincluded=1&...

When setting action=post the invoice wil directly be posted, but without taxincluded which is not what I want.

Has someone having the same problem or am I doing it wrong ?

If not, this might be a worth patching the code. I have been searching for the right place in the code, but since I am not familiar with perl I was not able to do it.

Maybe someone could help to point out the place in the code where to fix it. I found the place where the taxincluded checkbox is checked if $form->{taxincluded} is true, but $form->{taxincluded} is always 0, regardless of the url argument given.


Thanks
Andi

ps: tested with version 3.0.8 (same with all previous versions too)

Dieter Simader(R)

04.08.2015, 20:19

@ Andreas Schweizer
 

taxincluded=1 when using cli interface has no effect

When I use the cli interface to programmatically add an invoice and the
argument taxincluded=1 is given, the invoice is setup without taxincluded.
The same happens when i want to post an invoice.

I use this url to add an invoice:
is.pl?path=bin/mozilla&action=add&type=invoice&...&taxincluded=1&...

When setting action=post the invoice wil directly be posted, but without
taxincluded which is not what I want.

Has someone having the same problem or am I doing it wrong ?

If not, this might be a worth patching the code. I have been searching for
the right place in the code, but since I am not familiar with perl I was
not able to do it.

Maybe someone could help to point out the place in the code where to fix
it. I found the place where the taxincluded checkbox is checked if
$form->{taxincluded} is true, but $form->{taxincluded} is always 0,
regardless of the url argument given.


Thanks
Andi

ps: tested with version 3.0.8 (same with all previous versions too)

taxincluded depends on the customer's setting and cannot be set from the commandline.

Back to index page
Thread view  Board view
986 Postings in 325 Threads, 327 registered users, 107 users online (0 registered, 107 guests)
SQL-Ledger User Forum | Admin contact
RSS-Feed
powered by my little forum