SQL-Ledger Homepage

SQL-Ledger User Forum

Forum index page

Log in | Register

Back to the forum
Board view  Mix view

[SOLUTION] or not? Character BUG - Unicode? (General)

posted by hartundweich(R) Homepage, Austria, 09.04.2016, 18:24


today I have solved this issue - I was not able to stop thinking about this issue...
I googled around for PERL and UTF-8 in conjunction with POSTGRESQL - and found some important note about "pg_enable_utf8" in DBD:Pg that says, that this thing is getting deprecated...
First I tried setting this option to "1" and "-1" - but other characters than the desired have been displayed. So I tried to remove "pg_enable_utf8" from source code and voila - everything is working like a charm when I add "AddDefaultCharset On" to my VHOST configuration...

Mozilla Firefox says in all Frames that encoding is Unicode and all data sent to the database are stored as they should be stored and getting them back to webfrontend also works perfect - all my special characters are shown - HURRA :-)

I'm using DBD:Pg 3.4.2 and DBI 1.634.0 as these are the stable versions for my gentoo system.

But now all my special characters are missing in my generated PDFs... changing from pdflatex to xelatex does not help... maybe my postgres database is not UTF-8 as it is trying to say? If I want correct PDF documents I have to reinsert "pg_enable_utf8 => 0" again...


Complete thread:

Back to the forum
Board view  Mix view
1006 Postings in 335 Threads, 361 registered users, 95 users online (0 registered, 95 guests)
SQL-Ledger User Forum | Admin contact
powered by my little forum