SQL-Ledger Homepage

SQL-Ledger User Forum

Forum index page

Log in | Register

Back to the board
Thread view  Mix view  Order
Reto Schoch(R)

19.09.2016, 15:47
 

Login returns 500 Internal Server Error after update of perl (General)

After updating perl from 5.22.2-3 to 5.22.2-5 I could no longer login. The apache server returned an internal server error in the browser and in /var/log/apache2/error.log the following error message:

Can't locate bin/mozilla/login.pl in @INC (@INC contains: /etc/perl /usr/local/lib/i386-linux-gnu/perl/5.22.2 /usr/local/share/perl/5.22.2 /usr/lib/i386-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/i386-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/i386-linux-gnu/perl-base) at /usr/share/sql-ledger/login.pl line 120.

[Mon Sep 19 20:45:29.127240 2016] [cgid:error] [pid 1709:tid 2978962240] [client ::1:48394] End of script output before headers: login.pl

Does anyone know this behaviour and can give me a hint on how to get around this?

Reto Schoch(R)

19.09.2016, 16:30

@ Reto Schoch

Login returns 500 Internal Server Error after update of perl

After updating perl from 5.22.2-3 to 5.22.2-5 I could no longer login. The
apache server returned an internal server error in the browser and in
/var/log/apache2/error.log the following error message:

Can't locate bin/mozilla/login.pl in @INC (@INC contains: /etc/perl
/usr/local/lib/i386-linux-gnu/perl/5.22.2 /usr/local/share/perl/5.22.2
/usr/lib/i386-linux-gnu/perl5/5.22 /usr/share/perl5
/usr/lib/i386-linux-gnu/perl/5.22 /usr/share/perl/5.22
/usr/local/lib/site_perl /usr/lib/i386-linux-gnu/perl-base) at
/usr/share/sql-ledger/login.pl line 120.

[Mon Sep 19 20:45:29.127240 2016] [cgid:error] [pid 1709:tid 2978962240]
[client ::1:48394] End of script output before headers: login.pl

Does anyone know this behaviour and can give me a hint on how to get around
this?

I found the reason for this behaviour in the changelog of the previous update for Debian testing:
perl (5.22.2-4) unstable; urgency=low

* Fix test failure when '.' has been removed from @INC
* Remove '.' from @INC by default (Closes: #588017)
+ this behaviour can (for now) be disabled by commenting out the
last line of /etc/perl/sitecustomize.pl

-- Dominic Hargreaves <dom@earth.li> Thu, 01 Sep 2016 11:47:02 +0100

After commenting out the last line it works like charm again.

Back to the board
Thread view  Mix view  Order
964 Postings in 318 Threads, 322 registered users, 153 users online (0 registered, 153 guests)
SQL-Ledger User Forum | Admin contact
RSS-Feed
powered by my little forum